UE4 – Linking DLL

— This way Didn’t work —  [1] Add include path, dll, lib in ProjectName.Build.cs PublicIncludePaths.AddRange( new string[] { // … add public include paths required here … “INCLUDE_PATH” } ); PublicDelayLoadDLLs.Add(@”CUSTOM_DLL.dll”); PublicAdditionalLibraries.Add(@”CUSTOM_DLL.lib”);   [2] Copy .dll and .lib in ProjectFolder/Binaries/Win64/ If .dll is missing UE4 shows the error message “Missing …

Unity3D – Related Posts

custom viewer https://www.blog.radiator.debacle.us/2016/06/working-with-custom-objectpreviews-and.html https://gist.githubusercontent.com/radiatoryang/a2282d44ba71848e498bb2e03da98991/raw/0f91a1578a934b479dbe7f845f08a738004173b0/SkinnedMeshObjectPreviewExample.cs   Unity3D cuda interop https://github.com/stereolabs/zed-unity    

Compile GLFW on Ubuntu

[ Configuration using CMake ] source code path is GLFW/, not GLFW/src/ The RandR library and headers were not found sudo apt-get install xorg-dev libglu1-mesa-dev Eclipse version: Mars (downloaded) [ Load Project using Eclipse ] File > New > Makefile project with existing files Folder: cmake_output_path/src/  

Install NVIDIA Graphics Card + Cuda 8.0/9.1 on Ubuntu

[ Install NVidia Graphics Card on Ubuntu ] Install Proprietary Nvidia GPU Drivers on Ubuntu 16.04 / 17.10 / 18.04 sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt update sudo apt install nvidia-390 [ Install Cuda 9.1 ] https://developer.nvidia.com/cuda-91-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1704&target_type=deblocal `sudo dpkg -i cuda-repo-ubuntu1704-9-1-local_9.1.85-1_amd64.deb` `sudo apt-key add /var/cuda-repo-<version>/7fa2af80.pub` `sudo apt-get update` `sudo apt-get install cuda` …

Cuda (8.0) project using Eclipse Nsight on Ubuntu (18)

Graphics Card: NVidia GTX 1080 (Compute compatibility 6.1) [ Installation ] Nvidia Cuda 8.0 supports gcc compiler verion below 5.0 gcc-4.9 https://stackoverflow.com/questions/48398475/fail-to-install-gcc-4-9-in-ubuntu17-04 mkdir ~/Downloads/gcc-4.9-deb && cd ~/Downloads/gcc-4.9-debwget http://launchpadlibrarian.net/247707088/libmpfr4_3.1.4-1_amd64.deb wget http://launchpadlibrarian.net/253728424/libasan1_4.9.3-13ubuntu2_amd64.deb wget http://launchpadlibrarian.net/253728426/libgcc-4.9-dev_4.9.3-13ubuntu2_amd64.deb wget http://launchpadlibrarian.net/253728314/gcc-4.9-base_4.9.3-13ubuntu2_amd64.deb wget http://launchpadlibrarian.net/253728399/cpp-4.9_4.9.3-13ubuntu2_amd64.deb wget http://launchpadlibrarian.net/253728404/gcc-4.9_4.9.3-13ubuntu2_amd64.deb wget http://launchpadlibrarian.net/253728432/libstdc++-4.9-dev_4.9.3-13ubuntu2_amd64.deb wget http://launchpadlibrarian.net/253728401/g++-4.9_4.9.3-13ubuntu2_amd64.debsudo dpkg -i gcc-4.9-base_4.9.3-13ubuntu2_amd64.deb sudo dpkg -i libmpfr4_3.1.4-1_amd64.deb sudo …